Vanilla 3.1 est sorti ! plus d'informations ici.
Ces discussions concernent des versions de Vanilla qui ne sont plus supportées. Nous vous conseillons fortement de mettre à jour votre installation vers la version la plus récente.

Gros phpbb3 vers Vanilla 2.8.3

rogerroger Messages: 35Membre
Bonjour,

Je suis sous Wamp pour faire des tests avant de me lancer pour de vrai sur mon serveur, avec une version de mon forum phpbb SEO. J'ai suivi le tuto https://www.unkorneglosk.fr/article/migrer-de-vanilla-1-a-vanilla-2-grace-a-vanilla-porter.php pour passer mon ancien phpbb3 vers la dernière version de Vanilla.

Premier problème : ma base de donnée est d'environ 750 Mo, donc énorme. Il a fallu environ une heure pour convertir la base.

Puis, j'ai eu cette erreur :
7LBFWDRCODUH.jpg

Une idée pour résoudre cette erreur ?

Merci ! ;)

Réponses

  • UnkornegloskUnkorneglosk Messages: 42Administrateur
    mai 2019 modifié
    Bonjour :)
    Je n'ai jamais fait de migration depuis phpBB, je me renseigne tout de suite.

    Site internet: unkorneglosk.fr - Twitter: Unkorneglosk

  • rogerroger Messages: 35Membre
    Merci ! ;)
    J'ajoute qu'il m'a quand même créé un fichier .txt.gz qui fait 103Mo.
    Je n'ai pas essayé de le restaurer sur Vanilla, car avec l'erreur qu'il m'a sorti, je pense que tout l'export n'a pas été fait ...
  • UnkornegloskUnkorneglosk Messages: 42Administrateur
    Je pense en effet que ce dernier n'est pas complet.
    Le Porter à planté lorsqu'il convertissait les messages privés des utilisateurs dans une organisation similaire a celle de Vanilla (d'où l'apparition de tables z_pm etc. dans la base de données normalement).
    Seulement il semble qu'un des sujets de ces messages privés n'est pas dans un format reconnu.

    Site internet: unkorneglosk.fr - Twitter: Unkorneglosk

  • rogerroger Messages: 35Membre
    Ok, je pense que je vais vider les tables des MP, qui ne sont pas le plus important ...
    Le plus important étant les comptes des membres, et bien sur les sujets et réponses.
    Je te tiens au courant de la suite, car je pense que j'aurai surement encore besoin d'aide ... :)
  • UnkornegloskUnkorneglosk Messages: 42Administrateur
    Pas de soucis je répondrais bien entendu :D

    Site internet: unkorneglosk.fr - Twitter: Unkorneglosk

  • rogerroger Messages: 35Membre
    mai 2019 modifié
    Bon, après la suppression des MP, lors d'un nouvel essaie d'export de base, j'ai enfin eu un "Success" !!! B)
    J'ai donc installé Vanilla sous PHP 7.2, sans problème.
    Mais je ne trouve pas le lien "import" dans l'administration ! :/
    J'ai pourtant bien ajouté la ligne "
    $Configuration['Feature']['Import']['Enabled'] = true;
    
    " dans le fichier config.php.
    Mais je n'ai rien de plus dans mon admin.
    Pourrais tu me faire une capture d'écran de l'endroit où s'affiche le lien ?
    Serait ce lié à mon serveur Wamp ? Comme je suis en local, ça ne fonctionnerai pas ?
    Si tu as une idée, parce que là, je sèche ...

    [Edit]Ca y est, je l'ai enfin vu, je ne sais pas trop ce que j'ai fais, mais l'import à commencer ! :)

    [ReEdit]Bon, c'est pas passé ... :(
    tjkj19vtchot.jpg
    Juste à cause de la dernière connexion d'après ce que je comprends ...
    C'est bête que l'on ne puisse pas sélectionner exactement ce que l'on veut absolument garder, car ça, ce n'est pas important pour moi ...
    Si tu as une solution ...
  • UnkornegloskUnkorneglosk Messages: 42Administrateur
    mai 2019 modifié
    C'est très étrange en effet, je n'ai pas vu de personne qui s'est plaint d'une migration depuis phpBB.
    Peut-être à cause de certains plugins ?

    Regarde dans ton export, ouvre-le avec np++ et verifie que les dates sont bien sous la forme
    YYYY-MM-JJ HH:MM:SS
    

    D'après le message d'erreur il semblerait que l'un d'elles soit vide. Lorsqu'une date n'est pas connue, elle devrait être "0000-00-00 00:00:00" et pas vide.

    Site internet: unkorneglosk.fr - Twitter: Unkorneglosk

  • rogerroger Messages: 35Membre
    mai 2019 modifié
    Impossible de tout vérifier, il y a plusieurs milliers de dates ! :/
    Par contre, tu m'as peut-être mis sur une piste ...
    Les messages posté aujourd'hui ou hier, sont indiqué comme cela "aujourd'hui" "hier".
    Peut-être que cela viendrait de là ?
    Je vais modifier l'affichage des dates, refaire un export, et voir ce que cela donne ...
    [Edit]Ça ne fonctionne toujours pas ... :(
    Je ne sais plus trop quoi faire là ...
    Si tu veux essayer de ton coté, je peux te faire une copie de mon export ?
  • UnkornegloskUnkorneglosk Messages: 42Administrateur
    Oui pas de soucis, par contre il faut que tu l'héberge quelque part (et en MP pour le lien pas en public) que je jette un œil à l'export

    Site internet: unkorneglosk.fr - Twitter: Unkorneglosk

  • RatroRatro Messages: 3Membre
    as tu essayé d'activer import sql only ?
  • rogerroger Messages: 35Membre
    mai 2019 modifié
    Ah non !?
    C'est quoi la différence ?
    [Edit]Avec "import sql only", j'ai un
    La table 'van.gdn_zuser' n'existe pas
    
    :/
  • UnkornegloskUnkorneglosk Messages: 42Administrateur
    juillet 2019 modifié
    Le problème semble être résolu en désactivant le mode Strict de MySql à l'aide cette commande:
    SET GLOBAL sql_mode = 'NO_ENGINE_SUBSTITUTION';
    

    Site internet: unkorneglosk.fr - Twitter: Unkorneglosk

Connectez-vous ou Inscrivez-vous pour répondre.